AMZ Disclaimer & Statement WordPress Plugin

Now Amazon Associates (or Amazon Affiliates) who use WordPress can easily display Disclaimer or Statement on their website with this AMZ Disclaimer & Statement plugin. This plugin supports 7 Amazon Associates programs (US, CA, UK, DE, FR, ES & IT).

amzdisclaimer-2Amazon requires their affiliate to identify themselves as members of the Associates Program, and we’ve heard stories about Amazon account get banned because their websites don’t have the required affiliate disclosure statement.

If you don’t want to experience getting a lot of violation warning like me, this plugin can save you a lot of time from having to copy-pasting the Disclosure text manually and keep your account save at the same time.

Download the plugin below :) Then let us know if this plugin solve your problem, post your comment & feedback below how I can make this plugin to serves you even better.

Plugin Preview:

amazon-disclaimer-general-setting amazon-disclaimer-language-setting

Download AMZ Disclaimer & Statement Plugin


* READ THIS: If you landed here from my email, check that email again you can download this plugin on attachment at the very bottom of my email that you received. Download there, don’t download from this page :)

Share this post or leave some comments let us know what do you think, it’ll be much appreciated.

Changelog
v1.1
– Add support for Amazon DE and Amazon IT

v1.0
– First release

Comments 2

  1. Ron July 8, 2015
    • LeoLover July 10, 2015

Leave a Reply